Archiv nach Kategorien: Allgemein

Blizzard auf Linux

Auf einer Zweitmaschine habe ich einmal probiert, wie gut sich Blizzard’s Spiele unter Linux installieren lassen.

Es gibt einige gute Quellen (siehe weiter unten) aus denen man schöpfen kann, wenn es doch mal nicht so gut klappt.

Kurz zu meinem verwendeten System, es ist ein kleiner Quadcore mit 2 Gigabyte Ram, sowie einer betagten ATI Radeon 4870, als Betriebssystem habe ich, da es einfach sein sollte, Ubuntu 12.4 verwendet.

Als Grafiktreiber wurde der propertiäre FGLRX Grafiktreiber dazuinstalliert.

Wine wurde anschliessend auf 1.6 aktualisiert. Play on Linux habe ich erwogen, jedoch wieder verworfen, da ich die Installation des Spiels über die Battle.net Desktop App durchführen wollte, und ggf. auch sehen möchte, ob sich darüber auch andere Spiele installieren lassen.

Über die Accountverwaltung (http://eu.battle.net) habe ich mir anschliessend die Software heruntergeladen und einfach mit WinE gestartet. Da ich schon früher erfolglos experimentiert hatte, war noch ein alter Blizzard Updater installiert, was zu einigen Fehlermeldungen führte.

Das entfernen des alten Updaters war recht einfach – dieser findet sich im Home-Verzeichniss im Ordner .wine (Strg+H drücken, um versteckte Dateien anzuzeigen). Dort befindet sich der Drive_c Ordner, dieser enthält den Ordner User, dieser den Ordner Application Data, wo sich dann auch der Battle.net-Updater versteckt hat. Nach der Löschung des Ordners startete dann auch das Setup problemlos und richtete die App ein. Leider ist sie beim ersten Start direkt abgestürzt. Auf WineHQ fand sich dann ein Workaround, scheinbar funktioniert das Nachladen interaktiver Inhalte in der App noch nicht.

– Start von Winecfg über die Konsole oder die Dash
– Unter Bibliotheken / Librarys über dbghelp eintragen und auf ‚Festlegen / Add‘ gehen
– Die Bibliothek anwählen und deaktivieren

Anschliessend sollte die App sich starten lassen. Das Setup von World of Warcraft liess sich anschliessend auch problemlos über die App durchführen, allerdings hat der Installer sehr lange in der Initialisierung verbracht, so das der Anschein erweckt wurde, das die Installation sich aufgehängt hat. Hier hilft jedoch ein Blick auf den neu erstellten Ordner World of Warcraft.temp – vergrößert sich dieser, findet der Download statt. Nach etwa 10 Minuten war das Spiel dann plötzlich bereits spielbar und konnte auch problemlos gestartet werden.

Für heute hat mir das dann auch erstmal gereicht. Da in dem Linuxrechner nur eine beschädigte Grafikkarte läuft, war ein Test des Spiels leider noch nicht möglich – wird jedoch noch nachgeholt.

So hübsch kann ein Mud auf dem Ipad aussehen …

Nachdem ich mir heute ein Ipad gegönnt habe, hab ich natürlich auch gleich einen Mudclient installiert um zu testen, wie das ganze aussieht.

Im Itunes Store gibt es genau einen Mudclient dafür:

Mud Client für Ipad

Ein gelungener, voll funktionsfähiger Client mit Eingabehilfen und konfigurierbaren Tasten zur vereinfachten Bedienung. So sieht das ganze dann aus:

Hübsche Darstellung eines Mudclients auf dem Ipad 2

Ziemlich schick, wie ich finde! Ein wenig Retro auf einem Gerät, das so ganz und garnicht retro ist. Ich werd noch ein bisschen damit herumspielen, aber metzeln und laufen und sich unterhalten geht schonmal super damit.

Erstschlag

Mal sehen, wie sich das hier noch die nächsten Wochen füllen lässt. Dieses blog wird kein universelles Thema haben, aber mit alle möglichen interessanten (oder auch nicht interessanten) Seiten des Lebens gefüllt werden. Nach Lust und Laune. :)